Login  •  Register


Loading License.lic when OPC UA server is not a standalone

Questions regarding the use of the .NET SDK 2.0 for Server or Client development or integration into customer products ...

Loading License.lic when OPC UA server is not a standalone

Postby SamuJubic » 13 Dec 2019, 14:40

Hello,

I created a test server using the tutorials and everything has been going smoothly for the most part. I am using a trial license and I've had no problems running my OPC UA server as a standalone application. However, I want to integrate this server into another application, which is a basic console application. The goal is to run the OPC UA server on the background in the application while the application does what it usually does. The server is started through dependency injection, with the generic main method turned into a start method that should do the things identically, no code has been touched. When the server is starting up, the following lines appear in the console:

11.03.42.375|0003|00|0|***TRIAL***UaSdkNetEval-3.0.0_Eval-Win32-Binary - ClientSDK enabled - ServerSDK enabled - KM Builder - Unified Automation -
11.03.42.400|0003|01|4|DEBUGGER DETECTED: Adding TraceConsoleListener.
11.03.42.440|0003|00|0|***TRIAL***UaSdkNetEval-3.0.0_Eval-Win32-Binary - ClientSDK enabled - ServerSDK enabled - KM Builder - Unified Automation -
11.03.42.453|0003|01|2|Generated default application settings.
11.03.42.462|0003|01|4|Processing Command Line: {<the executable location of my application>}
11.03.42.487|0003|01|1|FindLicense Failed: ProductKey mismatch (here are two keys which it compares, one is my license key for sure and the other one is...some other key? It clearly finds my key from the license file I provided but something fails here)

So...why is this? I was expecting the application to just start up. Is this out of the scope for a trial license? Am I supposed to load the license with something else than AddProcessLicenses? Am I doing something wrong and it's probably related to my console application? Am I supposed to just keep the server as a standalone and run it separately?
SamuJubic
Jr. Member
Jr. Member
 
Posts: 1
Joined: 13 Dec 2019, 14:28

Re: Loading License.lic when OPC UA server is not a standalo

Postby Support Team » 13 Jan 2020, 13:38

Hello,

This is the standard trace if a trial license is used. The application should start normally.

I assume that the configuration file of your application is not found, so a default configuration is used. The default configuration enables the trace and the trace is printed as debug output. If the configuration file cannot be loaded after you changed the structure of your application, you should set the configuration in code.
Best regards
Unified Automation Support Team
User avatar
Support Team
Hero Member
Hero Member
 
Posts: 2439
Joined: 18 Mar 2011, 15:09


Return to .NET based OPC UA SDK

Who is online

Users browsing this forum: No registered users and 0 guests