unittest fails from build.sh

Questions regarding the use of the High Perfomance SDK for Server development

Moderator: uasdkhpc

Post Reply
mifhs
Jr. Member
Jr. Member
Posts: 1
Joined: 24 Jul 2020, 10:10

unittest fails from build.sh

Post by mifhs »

Hi,

I called build.sh (no arguments) from a fresh uasdkhpbundle-1.5.2 on a Ubuntu 18.04 system and test uaapplication test fails. Why? Am I missing a dependency?

Code: Select all

./build.sh
...
        Start 128: test_config
128/128 Test #128: test_config ......................   Passed    0.00 sec

99% tests passed, 1 tests failed out of 128

Total Test time (real) =  28.93 sec

The following tests FAILED:
	114 - test_uaapplication (Failed)
Errors while running CTest
Makefile:72: recipe for target 'test' failed
make: *** [test] Error 8

User avatar
Support Team
Hero Member
Hero Member
Posts: 2775
Joined: 18 Mar 2011, 15:09

Re: unittest fails from build.sh

Post by Support Team »

Hi,

This can have lots of reasons like permissions problems, old certificates, OpenSSL version problems, etc.
You need to run it again and look at the output of the test to say more. The test summary does not contain any detailed information to analyze the cause.

Code: Select all

cd path/to/sdk/bin
./test_uaapplicationd
Please use the support form to report issues and insert all the required information like version, platform, compiler, etc.
You can attach the complete build log as well, which contains the found OpenSSL version, and more.
https://webdav.unifiedautomation.com/support/support_form.html
Best regards
Unified Automation Support Team

Post Reply