Compatibility dotnet 5 and linux

Questions regarding the use of the .NET SDK 2.0 for Server or Client development or integration into customer products ...

Moderator: uasdknet

Post Reply
ftanguy
Full Member
Full Member
Posts: 5
Joined: 02 Apr 2021, 08:04

Compatibility dotnet 5 and linux

Post by ftanguy »

Hi All,

is the Server SDK compatible with dotnet 5 ?

If yes, is it possible to deploy the server on a linux ?

BR,
François

User avatar
Support Team
Hero Member
Hero Member
Posts: 2649
Joined: 18 Mar 2011, 15:09

Re: Compatibility dotnet 5 and linux

Post by Support Team »

Hello Ali,

our SDK provides Net Standard 2.0 assemblies.
In terms of Microsoft's backward compatibility, this means that our SDK is compatible with .Net 5.0.
But we haven't tested it yet. A server built in Net 5.0 with our .Net Standard dlls will run, but we can't guarantee it will run without problems.

We are working on official .Net 5.0 compatibility with our next major update.

And yes, it is possible to deploy a server build with our .Net Standard assemblies on Linux. Please use .Net Core 2.1 Runtime to avoid issues we found with .Net Core 2.0.
Best regards
Unified Automation Support Team

ftanguy
Full Member
Full Member
Posts: 5
Joined: 02 Apr 2021, 08:04

Re: Compatibility dotnet 5 and linux

Post by ftanguy »

Understood, thanks.

Post Reply