Use newer or update Opc.Ua.NodeSet2.xml files

Questions regarding the use of UaModeler

Moderator: uamodeler

Post Reply
kratsching
Jr. Member
Jr. Member
Posts: 2
Joined: 06 Aug 2015, 13:44

Use newer or update Opc.Ua.NodeSet2.xml files

Post by kratsching »

Hello everybody,

unfortunetaly the search didn't help, so here is my question:

I'm trying to use the current Opc.Ua.Nodeset2.xml from the OPC Foundation Github repository as it supports the variables "AvailableStates" and "AvailableTransitions" within the "FiniteStateMachineType". Now here is the problem: I cannot load the xml file. The import produces failure messages/output messages. I atteched a screenshot to this post --> UPDATE: I cannot uplaod an attachment, so here is the output:

Code: Select all

Error in xml file C:/Users/.../.../Repositories/OPC Foundation/UA-Nodeset/Schema/Opc.Ua.NodeSet2.xml.
line 25504, column 60: Element {http://opcfoundation.org/UA/2011/03/UANodeSet.xsd}Definition contains unknown attribute IsOptionSet.
Could not import model file. Model C:/Users/FAPS Dev/Desktop/Repositories/OPC Foundation/UA-Nodeset/Schema/Opc.Ua.NodeSet2.xml invalid.
This is my workflow:
1) I added some more Nodeset.xml files to the bin\models folder of the UaModeler
2) I chose the desired NodeSet2.xml file while creating a new project.
3) UaModeler tells me, that the xml file will be convertet to the ua file format
4) The programm crashes, telling me that "A source code generator for UA SDKs doesn't work any longer".

Where is my mistake? How do I use or import the newest versions of the OPC NodeSet2.xml files?

Here is some more information about my setup: Windows 10 (64bit), UaModeler 1.5.2 398

If you need more information, let me now.

Best regards

kratsching


UPDATE:

I just removed all the occurences of the attribute isOptionSet="true" from the Opc.Ua.NodeSet2.xml file just to check if the UaModeler will accept it. Now the error message says "Chosen model file is not a valid input for the UaModeler".

User avatar
Support Team
Hero Member
Hero Member
Posts: 2532
Joined: 18 Mar 2011, 15:09

Re: Use newer or update Opc.Ua.NodeSet2.xml files

Post by Support Team »

Hello,

Replacing the OPC Foundation namespace is neither tested nor released by UaModeler.

UaModeler 1.6 contains one of the latest versions of the OPC Foundation namespace.
Best regards
Unified Automation Support Team

Post Reply