When Connecting to PLC Server I Get an 0x8005000 Error

Questions regarding the use of the UaExpert.

Moderator: uaexpert

Post Reply
zarcram
Jr. Member
Jr. Member
Posts: 2
Joined: 06 May 2021, 08:54

When Connecting to PLC Server I Get an 0x8005000 Error

Post by zarcram »

Dear all,
I get the same error trying to connect to an OPC UA server on a Siemens S7-1513 PLC (firmware 2.5). The OPC UA expert is the Ubuntu version working on Ubuntu 18.04 .
The OPC UA expert file is UaExpert-1.5.1-331-x86_64.AppImage. The file is executed using the run command after right cliking the file.
As proposed in an other post I tried to record with wireshark.The server is located on IP 172.20.1.99 and the OPC UA expert on IP 172.20.1.197. Below the export from wireshark (as csv) after an attempt to connect to the server:

"No.","Time","Source","Destination","Protocol","Length","Info"
"1294","1218.747736564","172.20.1.197","172.20.1.99","TCP","74","60736 > 4840 [SYN] Seq=0 Win=64240 Len=0 MSS=1460 SACK_PERM=1 TSval=3253709550 TSecr=0 WS=128"
"1297","1218.749052260","172.20.1.99","172.20.1.197","TCP","60","4840 > 60736 [RST, ACK] Seq=1 Ack=1 Win=0 Len=0"
"1298","1218.749777023","172.20.1.197","172.20.1.99","TCP","74","60738 > 4840 [SYN] Seq=0 Win=64240 Len=0 MSS=1460 SACK_PERM=1 TSval=3253709552 TSecr=0 WS=128"
"1299","1218.750509059","172.20.1.99","172.20.1.197","TCP","60","4840 > 60738 [RST, ACK] Seq=1 Ack=1 Win=0 Len=0"
"1300","1218.751170841","172.20.1.197","172.20.1.99","TCP","74","60740 > 4840 [SYN] Seq=0 Win=64240 Len=0 MSS=1460 SACK_PERM=1 TSval=3253709554 TSecr=0 WS=128"
"1301","1218.751834713","172.20.1.99","172.20.1.197","TCP","60","4840 > 60740 [RST, ACK] Seq=1 Ack=1 Win=0 Len=0"

We can see OPC UA expert client sent 3 frames, each time from a different PORT and the server answer to the right port.
Did somebody find a solution for this problem or could give me a hand ?
Many thanks for the attention.

User avatar
Support Team
Hero Member
Hero Member
Posts: 2670
Joined: 18 Mar 2011, 15:09

Re: When Connecting to PLC Server I Get an 0x8005000 Error

Post by Support Team »

Hi,

the hint is:
0) ping on the target IP (telnet on the port, just to make sure your network is alive)
1) check the log window of UaExpert
2) if not getting enough information, switch on the trace in UaExpert
3) if not enough information, select deep trace level
4) only if the 3 above did not give enough insights, use wireshark (with UA dissector plugin and filtered on UA traffic only)

The information you present in your post is of no use at all.
Best regards
Unified Automation Support Team

Post Reply