Could not verify message signature

Questions regarding the use of the UaExpert.

Moderator: uaexpert

Post Reply
cvdinh
Jr. Member
Jr. Member
Posts: 1
Joined: 20 Apr 2021, 17:11

Could not verify message signature

Post by cvdinh »

Hi,
I am using UaExpert to connect to my server. I am able to browse node and see data. However, about every 10 ore 15 minutes, it seems communication is lost with the error message:
[uastack] OpcUa_SecureStream_VerifyInputBuffer: Could not verify message signature!
[uastack] OpcUa_SecureConnection_ProcessSessionCallResponse: Could not append chunk! (0x80130000)
[uastack] OpcUa_TcpSecureChannel_SequenceNumberReceived: Sequence number at channel 65 has invalid value 553! (Last: 551)
[uastack] OpcUa_SecureConnection_ProcessSessionCallResponse: Could not append chunk! (0x80010000)
...

Any ideas if it's the server or UaExpert issue?
Notice that I have multiple clients connected to the server. While this happens to this client, the other clients still reading nodes from the server fine.
Thanks.

User avatar
Support Team
Hero Member
Hero Member
Posts: 2670
Joined: 18 Mar 2011, 15:09

Re: Could not verify message signature

Post by Support Team »

Hi,

curious to ask who's server that is, but you probably better return to manufacturer.

The error is clearly in the server which has a serious error in the protocol stack implementation. It seems that the chunks (message fragments) and/or caused by that the sequence numbering is out of control.

You should either use "certified" OPC UA implementations (certified for compliance by the OPC Foundation) or your should use implementations that at least have attended IOP (inter operability workshop), hence have prooven that they comply to the protocol specification.
Best regards
Unified Automation Support Team

Post Reply