Page 1 of 1

Connection with ET200SP failed

Posted: 02 Mar 2020, 13:18
by kemmerichan
I tried to connect a ET200SP (UA Server) with the UaExpert. Without certification i get a connection. When i try to connect with Secrity Police i get the following error's:

11:56:53.435Z|2|1518* [uastack] OpcUa_TcpConnection_ProcessResponse: Error Message!
11:56:53.435Z|2|1518* [uastack] OpcUa_TcpConnection_ProcessResponse: Status 0x80160000!

The certifikation from the UaExpert is imported in the PLC and the certertification and the .crt -List is copy to the UaExpert and displayed in theCertification Manager.

Re: Connection with ET200SP failed

Posted: 04 Mar 2020, 10:19
by kemmerichan
I found the solution. In the automatic generated certificate was only a Domain Name listed. But i was direct connected with the PLC. I generate an new certificate with IP Adress from my Laptop. Now it works.

Re: Connection with ET200SP failed

Posted: 28 Apr 2020, 18:48
by Support Team

the if the domain name can not be resolved the validation of the certificate would be weak (and therefore is rejected). The idea is to be able to detect man in the middle attackers that use certificates that do not belong to them (their domain). For that reason it is important to have a proper IT infrastructure in place then using OPC UA and the security features.