Problems with Alarms & Conditions

Questions regarding the use of the UaExpert.

Moderator: uaexpert

Post Reply
PUSHFD
Jr. Member
Jr. Member
Posts: 2
Joined: 06 Sep 2019, 06:33

Problems with Alarms & Conditions

Post by PUSHFD »

Hello

I’m using an OPC UA Server on a PLC which supports Alarms & Conditions, the manufacturer says. I’m using UaExpert Version 1.5.1 331 for testing. The UA server on the PLC is running, I can drag and drop the variables into the data access view and see the values changing. But I can not see the condition controller in the objects path. And I can not drag and drop any variables into the Event View. I already contacted the support of the PLC manufacturer, they say the OPC UA and A&C configuration should be correct. But I get no A&C on the UaExpert.

Do I need to install a plugin or anything to see condition controllers? Do I have to change any settings or configurations of the UaExpert?

Tanks in advance and regards, PUSHFD

User avatar
Support Team
Hero Member
Hero Member
Posts: 2519
Joined: 18 Mar 2011, 15:09

Re: Problems with Alarms & Conditions

Post by Support Team »

Hello,

the easiest way to check for Events is to open the A&E-View in UaExpert and drag&drop the "Server" object into the view. You must browse into the "Server" object, that is the highest object in the event hierachy. In most servers you will find more objects with "hasEvents" when drilling into the "Server" object. However when you subscribe for the "Server" object, you will get "all" the alarms and events.
Best regards
Unified Automation Support Team

Post Reply