Cannot connect with hostname on a second computer

Questions regarding the use of the UaExpert.

Moderator: uaexpert

Post Reply
DavidBo
Jr. Member
Jr. Member
Posts: 1
Joined: 23 Nov 2021, 17:54

Cannot connect with hostname on a second computer

Post by DavidBo »

I have 2 Windows 10 clients and the server is a Linux Debian server
With the first Windows Computer I get
14:15:20.050 | Server Node | OPCUAServer@harmonia-05 | Connection status of server 'OPCUAServer@harmonia-05' changed to 'NewSessionCreated'.
14:15:20.051 | Server Node | OPCUAServer@harmonia-05 | Namespace table changed, mapping old to new namespace indices
14:15:20.051 | Server Node | OPCUAServer@harmonia-05 | Connection status of server 'OPCUAServer@harmonia-05' changed to 'Connected'.

With the second it fails
7:41:43.393 | Server Node | OPCUAServer@harmonia-05 | Endpoint: 'opc.tcp://harmonia-05:4840'
17:41:43.393 | Server Node | OPCUAServer@harmonia-05 | Security policy: 'http://opcfoundation.org/UA/SecurityPolicy#None'
17:41:43.393 | Server Node | OPCUAServer@harmonia-05 | ApplicationUri: 'urn:harmonia-05:3S%20-%20Smart%20Software%20Solutions%20GmbH:CODESYS%20Control%20for%20Raspberry%20Pi%20SL:OPCUA:Server'
17:41:43.393 | Server Node | OPCUAServer@harmonia-05 | Used UserTokenType: Anonymous
17:41:43.393 | Server Node | OPCUAServer@harmonia-05 | The server returned no certificate, all certificate checks will be skipped.
17:41:45.685 | Server Node | OPCUAServer@harmonia-05 | Error 'BadHostUnknown' was returned during OpenSecureChannel
17:41:45.686 | Server Node | OPCUAServer@harmonia-05 | Connection status of server 'OPCUAServer@harmonia-05' changed to 'Disconnected'.

I can connect by using the IP address and I can do a DNS lookup. The server also has Web server and I have no problems with accessing the webserver with a browser. As far as I can tell the firewall on the client seems to be open for OPC, but I am not a Windows 10 firewall expert.
What can be wrong ?

Post Reply