UAExpert displays Unknown ExtensionObject on structured data type

Questions regarding the use of the UaExpert.

Moderator: uaexpert

Post Reply
sschwinn
Jr. Member
Jr. Member
Posts: 1
Joined: 06 Oct 2021, 08:17

UAExpert displays Unknown ExtensionObject on structured data type

Post by sschwinn »

Greetings to all of you,

I am currently working on structured data types and their encoding/decoding and I stumbled on the following problem:

The UAExpert (Version 1.5.1 331) does not display structured data types. Instead it displays the value as an unkown extension object. I cross checked the correct encoding and decoding of the data with another OPC UA Client (Softing), where it was displayed correctly.

Currently the following Nodes were created for the representation of the data types:
- The data type itself, with "Structure" as parent node
- An object node with "Default Binary" with a "HasEncoding" Reference from the data type
- A variable node with the data type name as a String
- A variable node with the BSD file contents as a ByteString. This node also has a HasComponent reference to the variable node above and a HasTypeDefinition reference to the DataTypeDictionaryType node. This node is also a component of OPC Binary
- A VariableType node with the data type as its type definition
- A test variable node on which i can write and read values from/to. The variable has the data type as its type definition and the VariableType with a HasTypeDefinition as a reference.

Unfortunately i was not able to make this work. As a base I used part 3 chapter 5.8 of the OPC UA reference. I think I am not far off, because the other OPC UA Client displays the structures correctly.
If further Informations are needed, feel free to ask for them.

Post Reply