Connection using Aes256_Sha256_RsaPss endpoint failed with BadApplicationSignatureInvalid

Questions regarding the use of the ANSI C SDK for Server or Client development or integration into customer products ...

Moderator: uasdkc

Post Reply
sureshmms
Jr. Member
Jr. Member
Posts: 1
Joined: 31 Aug 2015, 11:47

Connection using Aes256_Sha256_RsaPss endpoint failed with BadApplicationSignatureInvalid

Post by sureshmms »

Hi Team,

Currently i was trying to integrate security policies Aes256_Sha256_RsaPss functionality in our platform.
Using ANSIC C based OPC UA SDK for our development.

After integration of security policies Aes128_Sha256_RsaOaep and Aes256_Sha256_RsaPss in our Server platform the Aes128_Sha256_RsaOaep functional behavior was working as expected.

However for Aes256_Sha256_RsaPss while try to connect UaExpert using Aes256_Sha256_RsaPss endpoint with our server, the pop up window on the UaExpert says that "BadApplicationSignatureInvalid" and in the log window "Server Application Signature is Invalid"

Can you please help in finding solution for this issue.

Regards
Suresh

User avatar
Support Team
Hero Member
Hero Member
Posts: 2768
Joined: 18 Mar 2011, 15:09

Re: Connection using Aes256_Sha256_RsaPss endpoint failed with BadApplicationSignatureInvalid

Post by Support Team »

Hi,

we have tested the issue with both algorithms/paddings the RsaPss and RsaOaep both work just fine using AnsiCDemoserver and the UaExpert.

This two "new" SecurityProfiles are supported in AnsiC based SDK since v1.8.0 (end 2017), however you may be using some very old codebase. In any case you should update to the latest v1.9.2 (including modern OpenSSL).
Best regards
Unified Automation Support Team

Post Reply