Problem of migration to the new ANSI C based OPC UA Client SDK v1.9.2

Questions regarding the use of the ANSI C SDK for Server or Client development or integration into customer products ...

Moderator: uasdkc

Post Reply
UlrichFM
Full Member
Full Member
Posts: 5
Joined: 08 Apr 2021, 08:55

Problem of migration to the new ANSI C based OPC UA Client SDK v1.9.2

Post by UlrichFM »

Hello, i was using the UaSdkCClient 1.9.1 version on linux without any problem but now when i tried to upgrade to the 1.9.2 version, i can't even connect me to the PLC. The errror i get is :
*****************************************************
405|W|96358280* ProcessOpenSecureChannelResponse: revised lifetime 3600000 below limit 4294967040.
.405|W|96358280* ProcessOpenSecureChannelResponse: Handling error 0x80AB0000.
:OPC_ConnectError_CB:
: ServiceType: OpenSecureChannel
: Error: 0x80ab0000
: Overridable: false
*****************************************************
even after several reconnection attempts the same errors appears.
To fix it, i tried these 3 methods :
1) I change the SecureChannelLifetime (by example to 4294967041) in the client_settings.conf file but the errors appears again : "revised lifetime 3600000 below limit 4294967040."
2) I manually change the SecureChannelLifetime of the UaClient_Session but the errors appears again : "revised lifetime 3600000 below limit 4294967040."
3) I manually change the SecureChannelLifetime of theUaClient_Configuration but the errors appears again : "revised lifetime 3600000 below limit 4294967040."

I realized that no matter where I try to change the SecureChannelLifetime (to make it superior than the limit 4294967040 mentioned in the error message), my change does not take effect and it is always the value 3600000 that remains. Can you tell me where to really modify it or how to solve my problem please.

Thanks

User avatar
Support Team
Hero Member
Hero Member
Posts: 2695
Joined: 18 Mar 2011, 15:09

Re: Problem of migration to the new ANSI C based OPC UA Client SDK v1.9.2

Post by Support Team »

Hi,
revised lifetime 3600000 below limit 4294967040
the server obiously has a maximum secure channel lifetime of 3600000 (one hour). However your Client demands a much higher value (longer) lifetime, hence being rejected with error. Therefore if you change the requested lifetime in the client_settings it should be in the range accepted by the server (which is most likely something between 10 min and 1 hour).

The value you are requesting "4294967040" is to big, my educated guess is that on client side both min. and max. secure channel lifetime seems to be "-1" (the initialization value), it was probably not set at all. You have to request a value smaller or equal to one hour and of course your own Min and Max settings should reflect that range as well, or at least have overlap with the server side, otherways negothiation will fail.
Best regards
Unified Automation Support Team

UlrichFM
Full Member
Full Member
Posts: 5
Joined: 08 Apr 2021, 08:55

Re: Problem of migration to the new ANSI C based OPC UA Client SDK v1.9.2

Post by UlrichFM »

Hello,

I confirm that the min and max of the secure channel lifetime are set to 300000 and 3600000 in the settings file. So, even with the max at 3600000, i still have the same error

UlrichFM
Full Member
Full Member
Posts: 5
Joined: 08 Apr 2021, 08:55

Re: Problem of migration to the new ANSI C based OPC UA Client SDK v1.9.2

Post by UlrichFM »

Hello,

Is there a problem with the new ANSI C based OPC UA Client SDK v1.9.2 ? Because even with good configurations :
SecureConnection_MinRevisedSecureChannelLifetime set to 300000
SecureConnection_MaxRevisedSecureChannelLifetime set to 3600000
and the SecureChannelLifetime set to 3600000,

my error is still the same :
*****************************************************
405|W|96358280* ProcessOpenSecureChannelResponse: revised lifetime 3600000 below limit 4294967040.
.405|W|96358280* ProcessOpenSecureChannelResponse: Handling error 0x80AB0000.
:OPC_ConnectError_CB:
: ServiceType: OpenSecureChannel
: Error: 0x80ab0000
: Overridable: false
*****************************************************

I still don't have any solutions

Post Reply