Failed to connect to 2.0 data access interface

Unified Architecture topics related to OPC UA Specification, compliant behavior and any technical issues of OPC UA, like Security, Information Model, Companion Specs DI, PLCopen, ADI, ...

Moderator: Support Team

Post Reply
z_jun
Jr. Member
Jr. Member
Posts: 1
Joined: 19 Jul 2013, 11:20

Failed to connect to 2.0 data access interface

Post by z_jun »

I have a WinCC OPC Server on a Windows 2000 machine. My WinCC OPC Server is on a workgroup.

I have two machines with OPC Quick Clients which wants to connect remotely to the WinCC OPC Server. Both are on domain but on different domains. Both are Windows 7. One is able to connect without any problems. The other, I tried to mimic all the DCOM and Local Security Policies but it still gave me the error "Failed to connect to 2.0 data access interface. Falling back to 1.0 interface".

For DCOM I have added Everyone, Self, System, Network, Administrators, Guests, Interactive, Anonymous Logon to have local and remote access. I have also added System, Network, Administrators, Guests, Interactive and Anonymous Logon to have local and remote launch and activation.

I have also set the Local Security Policies to have Network access: Sharing and security model for local accounts: Classic-local users authenticate as themselves" and Network access: Let Everyone permissions apply to anonymous users: Enabled.

I do not have identical users on all the machines because I am trying not to touch the WinCC OPC Server settings and I figured that if one machine is able to access it I should be able to do the same to the other. Is there any other settings that I should take note of? Thanks in advance.

User avatar
Support Team
Hero Member
Hero Member
Posts: 2532
Joined: 18 Mar 2011, 15:09

Re: Failed to connect to 2.0 data access interface

Post by Support Team »

First of all you should follow the Checklist:
http://www.ascolab.com/images/stories/a ... v1.0_x.pdf

Second, the WinCC server can run in different "modes" depending on the "mode" of the WinCC project. Since new WinCC V7 you can create a project that runs in "service mode" which meanns that the WinCC OPC Servers will run as "NT-service" as well. This service will run in the "system" context of the WinCC machine.

The Quick Client can already connect to the WinCC OPC Server, so the "lauch permission" seem to be correct.
the error "Failed to connect to 2.0 data access interface. Falling back to 1.0 interface.
This error is a little "missleading", the Client tries to register a callbackinterface on the Server so that the server can send information/data back to the client. This obviously did not work, so that the Client got the impression that the interface does not "exists" and tries to fall back on an "older" interface. Anyway, the reason could be that the WinCC Server is not allowed to call back to the client, therefore you should look at the client-side "access permissions". Here you must allow to be accessed by the servers context.

From you description it seems that you have done all the correct steps (and more) regarding the DCOM settings already, but you should check the access permissins and the ACL limits again and make sure the "Network"and "System" is in there and you should check for the context the WinCC OPC Server is running in and also include that in ACL and access permission.

Post Reply