Login  •  Register


Error connecting two S7 1500 OPC UA Servers at the same time

Questions regarding installing, running and configuring UaGateway.

Error connecting two S7 1500 OPC UA Servers at the same time

Postby hbbend » 21 Feb 2019, 19:18

Hello,
I have two PLCs I want to connect to FLEXSIM through OPC using UAGateway as a proxy (OPC UA to OPC classic).
Endpoints are as following:
PLC 1 : opc.tcp ://192.168.0.11:4840
PLC 2 : opc.tcp ://192.168.0.5:4840

I got Error while trying to connect two S7 1500 OPC UA Servers to UA Gateway at the same time:
- The first server connects correctly
-The second server could not connect , error message: "Configuration error - Duplicated Server"

Do you have any idea how to solve this problem

Thank you for your help

Best Regards
hbbend
Newbie
Newbie
 
Posts: 1
Joined: 09 May 2017, 13:26

Re: Error connecting two S7 1500 OPC UA Servers at the same

Postby Support Team » 27 Feb 2019, 18:19

Hello hbbend,

you can configure UaGateway only to connect to the same server once. To identify a server we use the entry on index 1 in the namespace array (which is equal to the ApplicationUri).
So I assume both instances of S7 1500 UaServers are configured to use the same ApplicationUri. You need to change that in the configuration tool shipped with the UaServer.
Best regards
Unified Automation Support Team
User avatar
Support Team
Hero Member
Hero Member
 
Posts: 2388
Joined: 18 Mar 2011, 15:09


Return to UaGateway

Who is online

Users browsing this forum: No registered users and 0 guests

cron