Login  •  Register


libcrypto.so.1.0.0 no version info on OpenSuse  Topic is solved

Questions regarding the use of the ANSI C SDK for Server or Client development or integration into customer products ...

libcrypto.so.1.0.0 no version info on OpenSuse

Postby nemethz » 27 Jun 2017, 08:45

Hi,

I get /lib64/libcrypto.so.1.0.0: no version information available (required by /lib64/libuastack.so) message when I run my application.
The OS is openSuse 13.2, I recompiled the OPC UA library and my application also on it, but not solved.
What can I do, have I recompile the OpenSSL also?

Btw it seems the application is working.

Thanks
Zoltan Nemeth
nemethz
Full Member
Full Member
 
Posts: 9
Joined: 14 Mar 2017, 09:10

Re: libcrypto.so.1.0.0 no version info on OpenSuse  Topic is solved

Postby Support Team » 15 Aug 2017, 09:07

Hello Zoltan,

please make sure that you link against the devel-libraries that match the OpenSSL libraries installed on your system. If they don't match, the warning you are seeing is being thrown. You should not be required to recompile OpenSSL on your own, as OpenSuse already brings a working version. See also: https://stackoverflow.com/questions/137 ... mic-linker
Best regards
Unified Automation Support Team
User avatar
Support Team
Hero Member
Hero Member
 
Posts: 2422
Joined: 18 Mar 2011, 15:09

Re: libcrypto.so.1.0.0 no version info on OpenSuse

Postby jozap » 26 Sep 2019, 13:49

i love this blog.
Information about the new version of the software that I have at my laptop were available at this it was good to have it. I need to get was at cheapwritingservice they have some professionals at this to work along the projects that will have to do after completing this.
jozap
Jr. Member
Jr. Member
 
Posts: 1
Joined: 26 Sep 2019, 13:47


Return to ANSI C based OPC UA SDK

Who is online

Users browsing this forum: No registered users and 0 guests