Login  •  Register


UaGateway connects to DA-Server, but no items are found

Questions regarding installing, running and configuring UaGateway.

UaGateway connects to DA-Server, but no items are found

Postby erg » 11 Sep 2015, 13:45

Hello.

We are evaluating UaGateway to provide UA-Clients a possibility to connect to an existing DA-Server.

The used OPC DA Server is the 'Saia-Burgess Controls AG & Merz OPC server', version 2.02.17.20 ( https://www.sbc-support.com/de/software/opc-server/ ).

The OPC Server is running and registered, ordinary DA-Clients (like the matrikon opc client) can successfully connect to the DA-Server, browse its items, add them and see the actual data from the PLC.

So we have installed the Unified Automation UaGateway, created the certificates and then started the configuration screen. We were able to successfully add the local DA-Server (showed up under the 'local' node). The UaGateway can successfully connect to the DA-Server (see attached screenshot).

Next, we started the Unified Automation UaExpert. In UaExpert we added the UaGateway Server and established a connection to it. If we then look at the 'Address Space' window we see below the 'Objects' node an entry for the 'Merz.OPC_SAIA_S-BUS.1.' server, but no items are shown.

We would be glad for any hints what could be wrong.

Notes:
- Its running on Windows 7 prof. 64bit.
- UaGateway is registered to run as auser with Administrative privileges, UAC is disabled.
- When I Stop Ua-Gateway, and then start it again, I see in ProcessExplorer that an instance of the corresponding DA-Server gets started (SBCSBus.exe and SCommDrv52.exe).
- Attached is a trace-file of the UA-Gateway.
You do not have the required permissions to view the files attached to this post.
erg
Newbie
Newbie
 
Posts: 1
Joined: 04 Sep 2015, 16:07

Re: UaGateway connects to DA-Server, but no items are found

Postby Support Team » 06 Oct 2015, 22:10

Hi,

The connection establishment to the server works fine and we cannot see any unexpected error or behaviour during connect.

But a call to BrowseOPCItemIDs always returns S_False (0x1) which means no browse results returned.
We call the method without any filter and with OPC_BRANCH and with OPC_LEAF on root. We have no idea what can go wrong here inside the server.

Code: Select all
12:08:07.051Z|4|1590* CALL IOPCBrowseServerAddressSpace::BrowseOPCItemIDs
12:08:07.051Z|4|1590* DONE IOPCBrowseServerAddressSpace::BrowseOPCItemIDs [hr=0x1]
12:08:07.051Z|4|1590* CALL IOPCBrowseServerAddressSpace::BrowseOPCItemIDs
12:08:07.052Z|4|1590* DONE IOPCBrowseServerAddressSpace::BrowseOPCItemIDs [hr=0x1]


Do you have a way to check the server log?

Best Regards,
Unified Automation Support Team
User avatar
Support Team
Hero Member
Hero Member
 
Posts: 2411
Joined: 18 Mar 2011, 15:09

Re: UaGateway connects to DA-Server, but no items are found

Postby Dominik » 09 Jul 2019, 08:45

Please follow these steps:
1. Stop OPC server, be sure in task manager that OPC server process is stopped
2. Start registry editor and carefully delete all entries in HKEY_CURRENT_USER\Software\Classes\VirtualStore\MACHINE\SOFTWARE\WOW6432Node\MERZ
3. Start OPC server´s configuration tool with privileges “As administrator” and mark your configuration as registered

All entries from OPC server (configuration, license) has to be written into HKLM location.
********************
Reason:
The problem with browsing can be caused by wrong registration of OPC servers´s configuration *.sbcfg file.
The correct place where path to *.sbcfg file has to be stored in windows registry is here: HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\MERZ\Merz SBC OPC S-Bus Server
The HKLM location is used only when you start configuration tool with administrator privileges (“Run as administrator”)

If you start program as standard user then Windows will redirect HKLM to per-user location
Computer\HKEY_CURRENT_USER\Software\Classes\VirtualStore\MACHINE\SOFTWARE\WOW6432Node\MERZ\Merz SBC OPC S-Bus Server

You can get more information about it here
https://docs.microsoft.com/en-us/window ... ualization
Dominik
Newbie
Newbie
 
Posts: 1
Joined: 09 Jul 2019, 08:39


Return to UaGateway

Who is online

Users browsing this forum: No registered users and 0 guests

cron